Are you ready to see the Cursed Legacy trailer?
We have updated our Forum Rules. Please take a moment to read through them: https://forum.deadbydaylight.com/en/discussion/87004/

Can’t join my mans in swf

When I invite him it says he joined the game and then a couple of seconds later says he left when he didn’t even enter a loading screen and is not in my game. It happens when he invites me to. We have both restarted the game and it didn’t help. We have also deleted the game and reinstalled it and it still won’t let me join him please help cause I am missing out on a lot of fun

Comments

  • Dafydd_playsDafydd_plays Member Posts: 4

    I am on PS4 btw

  • paulodasoopaulodasoo Member Posts: 3

    I do have the exact same problem.

    Since the last patch, neither me nor my friend are able to accept lobby invitations to play together. We don‘t even get a loading screen or the typical „change your NAT“ message. Only if we try to connect from the main menu, we get the message „invitation can‘t be accepted“ or something like this.

    We both have NAT 2, opened all our ports and stuff, we even tried not to invite but instead join each other - won‘t work either.If we try to join from the lobby our game softlocks (?) and we can‘t leave the lobby screen or open the friends menu.We never had such problems in the past and if we had, we got at least a loading screen and the NAT-message.

    I searched on google and different forums but didn‘t find anything about it.

  • KhaineGBKhaineGB Member, Mod Posts: 739

    Try NAT 1 instead of NAT 2.

    I need to double check if that's still required on PS4, but that's what we were being advised before the Stranger Things patch.

  • Dafydd_playsDafydd_plays Member Posts: 4
  • paulodasoopaulodasoo Member Posts: 3

    You can‘t just change your NAT, it‘s not like there is such an option in your router menu, PS4 or anything.

    The NAT works over ports and I made my PS4 exposed host (all ports opened). There is LITERALLY nothing I can do to make it „more open“.

    Also, NAT 2 was never a problem in the past; other games and lobbys with some other players work.

    This is just weird.

  • KhaineGBKhaineGB Member, Mod Posts: 739

    Yeah, I know it's not a setting in routers. I need to actually research what Sony says the difference is between the two. I usually just turn the firewall of my router off because it's pretty terrible.

    But I'll ask if NAT 1 vs NAT 2 is still needed or not. As I said, before ST dropped it's what we were informed to recommend. I want to check that's still the case. :)

  • Dafydd_playsDafydd_plays Member Posts: 4

    I don’t get why it is happening suddenly because we were playing earlier on in the day and then when we tried to join each other again it wouldn’t let us

  • KhaineGBKhaineGB Member, Mod Posts: 739

    I don't get it either.

    I think I remember a post last week where folks were sending invites from the ARCHIVES screen and that was somehow working, and I'm pretty sure that's PS4.

    Maybe give that a try and let me know? If it works, I can report that as a workaround and maybe it'll help fix... whatever is going on.

Sign In or Register to comment.