Home Bug Reports Other
We're currently investigating issues with frame rate on PS4 after the most recent update. Thank you to everyone for bringing this to our attention, and for your patience while we look into this
You are currently reviewing the archived bug reports section. To report a new issue, please use the new bug reports section found here: https://forum.deadbydaylight.com/en/categories/bugs
If you are experiencing the Rank Update Error, please click here: https://forum.deadbydaylight.com/en/discussion/125133/

Reverent Tome Challenge Broken

notsoscarrednotsoscarred Member Posts: 2

Platform: PS4

Issue: The challenge Reverent in Tome 1 on the second level isn’t working at all. I have been stuck with it for awhile now. I am suppose to sacrifice survivors to the entity but nothing counts to it. Before playing as a survivor and dying would count but now nothing counts and I'm stuck with it.

Comments

  • Happyfoolx4Happyfoolx4 Member Posts: 1

    I have the same issue on PC, apparently using Ebony or Ivory mori's might work but I'm not to sure. This Tracked fine for me before the last update I think (there may have been more before I started playing again, it was fine after the previous rift cloesd).

    Stuck at three, other challenges I've tried are fine

  • Koro76Koro76 Member Posts: 5
    edited January 28

    I'm having the same problem on PC with the 5 sacrifice Reverent in tome 1, chapter 1. I'm stuck on 4/5 sacrifices.

  • HjtunfgbHjtunfgb Member Posts: 2
    edited January 28

    I'm having the same issue on PC. I remember that Golden Age was working for killer emblems only, but I was still able to win all 20. However, Reverent does not progress at all. I tried 2 different killers and 2 different survivors(I was told it was glitched and counted fellow survivors/self sacrifice), but nothing worked and I can't progress my entries for Blood, Brass and Grit or The Entity.

    Edit: both my issues are on tome 1, level 2

  • Rocker719Rocker719 Member Posts: 2

    I'm on PS4 as well. I got three stacks for the quest and have been unable to get a single one past that. I've tried as three different killers, with varying amounts of sacrifice kills in each. I'm going to abandon this quest until I hear that it is fixed.

  • Koro76Koro76 Member Posts: 5
    edited January 30

    My problem in Tome 1 Chapter 1 resolved after I finished a different tome challenge. However, I'm stuck on Reverent 5/13 again in Tome 1 Chapter 2.

    Update: Tried swapping tome challenges and got some more progression, but stuck again at 9/13.

    Post edited by Koro76 on
  • hannibal322hannibal322 Member Posts: 11

    I have tried it with tome 1 and tome 2 and cannot make progress on either. On tome 1 i got 1 to count but idk how.

  • hannibal322hannibal322 Member Posts: 11

    I went and did a bunch of other challenges and came back to this and I still can't progress. Which sucks because I love lore and I can't get to the stuff locked behind this challenge

  • hannibal322hannibal322 Member Posts: 11

    I think I finally solved this thing. My sacrifices only seem to count if I get them in the end game collapse. I am fairly new to the game so am I just misunderstanding sacrifice to entity.

  • GORRILANATOR101GORRILANATOR101 Member Posts: 1

    I have the same problem on Xbox. Tome 1 level 2 reverent, I’m stuck at only two sacrifices and I tried various killers.

  • ransak123ransak123 Member Posts: 1

    Platform: PC

    Description of the issue: The challenge Reverent in book one, in the compendium, does not update sacrifices after each game.

    Steps to reproduce (if possible): Play the game and sacrifice any survivor with any killer on any map, and it will not count towards your total sacrifices.

    How often does this occur: Every game.

    Date is 3/9/2020

Sign In or Register to comment.