The 3.3.0 PTB has been closed. Please be sure to leave any feedback you may have here: https://forum.deadbydaylight.com/en/categories/3-3-0-ptb
If you have a moment, we'd also appreciate if you could fill out The Archives survey: https://www.surveymonkey.com/r/J83Q56Z
Thank you!
The stench of rotting Pustula Plants fills the air: https://forum.deadbydaylight.com/en/discussion/93854/
Some players have been facing an issue that causes partial loss of progress. We found one cause of the issue and are planning a fix for the mid-chapter update. In the meantime you can use this workaround: restart the game client after using the Custom game feature. Thank you.
We have updated our Forum Rules. Please take a moment to read through them: https://forum.deadbydaylight.com/en/discussion/87004/

Initialization Error on Xbox over and over

I bought this game and almost all of the DLC with my friends on xbox recently. When I try to play the game I am getting the "Initialization Error" over and over. I have tried deleting and redownloading the game. Tried on a different Gamer Tag, different xbox, different internet connection. Nothing seems to fix this problem. Browsing on the forums it appears that this is still a problem for many users. Has anyone found a way to fix this that I haven't tried or is this totally on the server side leaving us waiting for a fix from the devs?

Comments

  • blasters27blasters27 Member Posts: 6

    Still unable to play this game. 2 patches came out this week and nothing has fixed this issue. Not sure what to do at this point. I guess if the Devs will not address this issue I will have to go back to Microsoft and request a refund for my purchase.

  • SuggestiveSuggestive Mod, Customer Support Posts: 39

    Please have a quick look at your NAT type and ensure it is set to "open".
    Additionally, can you tell us if you're a part of the XBOX Insider program? (if yes - try opting out and see if that allows you in).

    If not, and your NAT type is indeed set to open, can you create a ticket over on support.deadbydaylight.com ? We're trying to gather some data on this at the moment.

  • blasters27blasters27 Member Posts: 6

    I checked my NAT and it is open. Also I was in the preview program and I opted out. It reset my xbox. I still cannot get past the initialization error.

    I created a ticket a week ago #284481

  • SuggestiveSuggestive Mod, Customer Support Posts: 39

    I see the ticket - it is with who is needs to be. As there's a lot of information coming in, it might be a little longer before you get a reply. Please bear with us.

  • blasters27blasters27 Member Posts: 6

    Any updates on this? I responded to the latest questions about using Wireless and WiFi connections and checking my NAT. Everything is open and I tried both types of connections. Not sure why this is still happening? My friends are playing and really enjoying the game so I'd really like to join them soon.

    One thing I remembered was that when I first attempted to play the game Xbox Live was having issues. All of us had to sign in multiple times before the Initialization Error went away. Unfortunately mine never did. Any chance the purchase could have been corrupted somehow? I would think deleting and redownloading it might help that. But I'm really just grasping at anything here.

  • blasters27blasters27 Member Posts: 6

    Any updates here? Haven't heard anything in over a week?

  • toystertoyster Member Posts: 6

    I had the same problem on the Xbox back in October after one of the updates. Kept giving me an initialization error. Tried everything- redownloaded it, uninstalled all DLC, resat the xbox, moved the game to various drives, quit the insider program, checked the NAT, etc. and nothing worked. Filed a ticket back in October and had a response that told me to do what I had already tried. After the second update after it stopped working (sometime in November) it started to let me play but i had to go through the initialization failed message like 5 times to do it. Update after that and it stopped working again and hasn't worked since. Even my save files were gone. Even tried to start it off a disc to no avail. Really liked this game and hate that i can't play. Stopped buying DLC and generally gave up on being able to play ever again. If you find something that works let me know.

  • LiquidAgLiquidAg Member Posts: 24

    I'm with y'all. I bought the game over 5 months ago, and I've never been able to play it. I've started support tickets, they offer the same troubleshooting tips, and then they talk about resetting my account, then it's silence for weeks on end. I'm so frustrated. I don't even want a refund, I want to PLAY!

  • camomnzcamomnz Member Posts: 7

    I fixed this today for myself when it happened. This method works only for XBOX One and I use it to fix network errors in my parties as well, I cannot promise it will fix the error for everyone.

    1. Go to Settings>Disc & Blu-ray>Blu-Ray>Persistent storage>Clear persistent storage (someone once told me to clear it 3 times, so I do, it takes not even a second)
    2. Go to Settings>Network>Network settings>Advanced settings>Alternate MAC address>Clear>Restart (this will turn off and restart your Xbox One, like you unplugged it)

    Again, idk if this will fix it for everyone, but it's the same fix i use when disconnected from Xbox live parties and works 99% of the time

  • LiquidAgLiquidAg Member Posts: 24

    Thanks, I'll have to try it and let you know if it works.

  • LiquidAgLiquidAg Member Posts: 24

    I haven't had a chance, yet. I'm planning to try it soon, but I've had other things get in the way. I also haven't felt as motivated to keep trying to log in, lately, because of my situation with the support team. It was very disheartening to have support tell me that my problem was unique, and they were working with Microsoft to fix it, but then they marked all my support tickets as "solved" and left it at that. I've had the game for over 6 months, now, and I've never played.

  • dr_strangelove10dr_strangelove10 Member Posts: 16

    It doesn’t work

  • camomnzcamomnz Member Posts: 7

    Guess it’s not a universal fix then

    I’d urge to try it though just in case it works for someone individually

    it’s a fairly common fix for a lot of Xbox problems and one of the first things that Xbox Support will ask you to do that actually works

  • camomnzcamomnz Member Posts: 7

    If anyone else tries, update the outcome

    It probs won't keep me up at night, but this last guy's commented nothing but negativity in threads and doesn't seem helpful at all, so won't taking their word as law

    If this worked glad it helped, if not then that's a downer and best wishes

  • LiquidAgLiquidAg Member Posts: 24

    Well, I finally got around to trying this tonight (as well as a few other suggestions), and it still hasn’t worked. Support says it’s something on Microsoft’s end, and all I can do is wait. But why have I never encountered this in ANY other game. Something tells me the design and coding of DbD is what’s causing the problem “on Microsoft’s end”. I guess I’ll try Microsoft next...

  • camomnzcamomnz Member Posts: 7

    ugh jeez, thanks yo

    no matter how much I’m into the game, this is just RIDICULOUS that tickets are being closed before anything is fixed and I’m seeing the same answer on forums

    I’m no Dev, but you’re likely right that it’s something with DbD’s compatibility on this console, which I GUESS makes is Microsoft’s end

    heads up, this thing I said will be something Microsoft will try to have you do

    this really shouldn’t be something we have to contact Microsoft for, rather this should be handled between the game and Microsoft...

  • LiquidAgLiquidAg Member Posts: 24

    I agree.

  • dr_strangelove10dr_strangelove10 Member Posts: 16

    LoL did get me going down this rabbit hole!

  • dr_strangelove10dr_strangelove10 Member Posts: 16

    Don’t get me*

  • dr_strangelove10dr_strangelove10 Member Posts: 16

    Again!

  • LiquidAgLiquidAg Member Posts: 24

    They fixed it!!  I don't know what they did (the patch notes don't mention it, as far as I can tell), but after the 3.2.0 update finished downloading, I was able to log in for the first time ever!  Now I can play the game that I bought over 7 months ago!

Sign In or Register to comment.