Home Technical Issues

My M1 and M2 need to be clicked up to 6 times to have them do anything

MoppotMoppot Member Posts: 9
edited August 2019 in Technical Issues

Recently I've been having an issue that has been happening in Dead by Daylight and only DBD. Whenever I'm killer or survivor I will have to click multiple times to do anything. It's making the game unbearable to play killer since I have the perfect time to attack but I end up having to click 4 or 5 times to do anything and then I'll end up doing a short swing and not going far enough. I know this all sounds like an excuse because I'm a bad but I've pushed through it and made it to rank 5 on both sides while dealing with the issue and I genuinely don't know what to do to fix it. And for the obvious solutions, no it's not my mouse as I recently got a new one because of the issue. Also, I've tried reinstalling the game but the issue still prevails through it and continues to be a nuisance in near all of my games. Any help or suggestions would be greatly appreciated.

Comments

  • KhaineGBKhaineGB Member, Mod Posts: 2,930

    Since you've done the obvious stuff (change mouse, reinstall the game, checked for the issue on other games) I'd submit a support ticket at https://support.deadbydaylight.com/hc/en-us

    My shot in the dark guess is it might be something to do with your mouse driver/software, but that is honestly just a guess. They might be able to go through what's running on your system and try to work out the issue. :)

  • Kind_LemonKind_Lemon Member Posts: 1,236

    I'm pretty sure it's because your mouse is going off screen (probs the right side). You may find that if you jerk your mouse to the left when that's happening that you should be able to click. What I've heard is that full screen mode is just a large, border-less windowed mode, and that's why the mouse can leave. Test to see what is happening with your mouse by playing a game in windowed mode.

    I have this problem myself, and changing computer scaling to 100% will solve the problem, but I can't do that because my game would be unplayable (that setting change inadvertently increases resolution, making it super laggy).

  • KhaineGBKhaineGB Member, Mod Posts: 2,930

    Setting your windows scaling to 100% does not increase resolution.

    It changes the text/icon size on your desktop. It's mostly intended for folks with greater than 1080p resolution. As an example, my main gaming rig was running at 125% scaling due to a 1440p panel to make everything look the same as it should on a 1080p panel.

    I turned that back to 100% and just put anything non-gaming on the other, 1080p panel and deal with it.

  • Kind_LemonKind_Lemon Member Posts: 1,236

    The above video is 100% scaling.

    The above video is 250% scaling. You can see that the settings are the same but that the resolution is now bearable on my PC.

  • KhaineGBKhaineGB Member, Mod Posts: 2,930

    Never had that issue on mine.

    If you can't/won't run scaling 100%, then lower your resolution in windows. That kinda looks like 4k.

  • XaggyXaggy Member Posts: 183

    Devs should tell us something about this issue. It's very annoying when I need to click 2-3 times to hit survivor. Funny is this is happening only in the chase.

  • Kind_LemonKind_Lemon Member Posts: 1,236

    I reduced my resolution in windows to the lowest, and then was able to run DbD at 100% scaling, meaning that my mouse would no longer go off my screen.

    This was a very annoying bug to go through and deal with, so I hope this thread helps someone else find his/her way.

    @KhaineGB , any word on why this happens?

  • KhaineGBKhaineGB Member, Mod Posts: 2,930

    Absolutely no idea at all.

    But as a 1440p user, I hope it gets fixed soon.

  • AlfredAlfred Member Posts: 272

    Windows 10

    4k 200% scaling = full HD DBD

    4k 100% scaling = 4k DBD (text is unreadable because of no scaling)

    Maybe you have to tell us the biggest secret of the Universe:

    Why this game does not have resolution option in menu?

  • KhaineGBKhaineGB Member, Mod Posts: 2,930

    I honestly wish I knew

  • HatCreatureHatCreature Member Posts: 3,298

    I'm having the same issue, updated Drivers, lowest DPI, switched ports etc. I don't think it's my mouse as I switched mice and it still happens so I will try this tomorrow myself and hope this works. I pray it does because I have missed so many hits and hook saves because of this problem.

  • HatCreatureHatCreature Member Posts: 3,298

    This did not work but it does look like the problem. I am still having the problem as my mouse is still clutching the side of the window but the effect is exactly the same problem I have in fullscreen. Can anything be done about this? It isn't happening to everyone so there must be something that can be done.

  • Ark_the_BonsaiArk_the_Bonsai Member Posts: 862

    Oddly enough setting your icon scaling to 100% (no more, no less) fixes it. No idea why but I haven't had a problem with it since and neither has anyone else I've suggested the fix to


    I'd love to know why it does that though.

  • HatCreatureHatCreature Member Posts: 3,298

    Icon scaling? I know when you go into a folder with pics and folders with too small icons it just shows the name so you make tho icon bigger to show the images but I doubt that's what you're talking about. Forgive my ignorance.

  • Ark_the_BonsaiArk_the_Bonsai Member Posts: 862

    Okay, this is an actual computer setting related thing.

    Go to your display settings and look for something that looks like this:

    For you that will normally be around 125%

    Setting it down to 100% completely fixes the issue with clicks not registering.

    The downside is that all of your icons and text will be scaled down. My fix for this is to go into each individual app and increase their text scaling while leaving the general scaling at 100%

    It's not as good as them patching the problem out but it's the only thing I've found that actually makes the game playable if you have that bug.

    Hope this helps man

  • Ark_the_BonsaiArk_the_Bonsai Member Posts: 862

    Sorry I called it icon scaling by the way. I forgot that it controlled text as well because I reset that to 125%-150% in individual apps. The only thing still shrunk down for me is the icons on my desktop so my brain went "icon scaling"

  • HatCreatureHatCreature Member Posts: 3,298

    I don't know why this but worked, I don't experience it at all now and it is very strange. I guess whenever I play DBD I have to change the display, weird. Thanks a bunch :)

  • Ark_the_BonsaiArk_the_Bonsai Member Posts: 862

    You're welcome man. I thought it was weird too. I have no idea what causes this bug but they really gotta fix it

  • MoppotMoppot Member Posts: 9

    Hey thanks for trying to help everyone, sadly none of the solutions have worked. For the icon scaling mine is always at 100% because it's recommended like that and for the play in the windowed version of the game it also doesn't work. If anyone happens to see a guaranteed fix for it or just anything else at all about it and would be willing to share maybe a link to it or a summary of what it said if you can't get the link for some reason here it would be greatly appreciated.

  • jb_bhvrjb_bhvr Member, Dev Posts: 12

    Hi Moppot, we've just spoken on Discord but for the benefit of others...

    Our QA's investigation has concluded that this issue is caused by the scaling setting on Windows 10.

    We recommend trying the workaround's that Microsoft sets out here: https://support.microsoft.com/en-ca/help/3025083/windows-scaling-issues-for-high-dpi-devices

  • ZensunimZensunim Member Posts: 68
    edited February 4

    @jb_bhvr

    Do you mind if I talk to you on Discord? This only occurs when text scaling is higher than 100%. The issue is very easily reproducible because it happens when the mouse cursor hits the bottom or right side of the screen, it moves 1 pixel outside the window area, causing an M1 to want to resize the gameplay window instead of registering as an attack. (Try playing in Windowed mode and it becomes very obvious.)

    The workarounds provided don't lead to a pleasant experience, especially in 4K where the text is nearly unreadable by most standards and the skill checks are half the size vs. 1080p.

    https://forum.deadbydaylight.com/en/discussion/comment/1062866


    Post edited by Zensunim on
  • DiegoticoDiegotico Member Posts: 1

    I've tried every fix mentioned on this thread, but I still can't seem to make the game work properly. It's like the game thinks I'm letting go of M1 when doing some actions that require me to hold M1 (unhooking, opening gates).

    I'm using Windows 10 with high-end specs, a newly bought mouse (and fully functional outside of DBD) and my scale to icons and texts is already set to 100%.

    Anyone has any other clues to fix this? Or at least a way to force the game to run on true fullscreen to stop this from happening?

  • KhaineGBKhaineGB Member, Mod Posts: 2,930

    Pretty sure the -fullscreen flag should force fullscreen.

    But I have the same issue on my desktop with my mouse. I usually have my finger around the middle of the mouse button. When playing DbD, I need to move it all the way to the front so the full button is held down to stop it.

    No idea why. Doesn't happen on any other games.

Sign In or Register to comment.