Home Technical Issues
The celebrations continue. :sparkler: The Entity has extended the Gilded Stampede event by an extra week. Log in daily to redeem 50,000 Bloodpoints for each extra day until the end of the event on March 4th 11AM EST!
https://deadbydaylight.com/en/news/lunar-new-year-2021

Can’t Sign In (Xbox)

ThatOneGuyThatOneGuy Member Posts: 219

When I try to sign in It says “Initialization Error” “The Game Initialized incorrectly and may not save your game properly. Restarting your game may resolve the problem” 

Ive restarted the game and console multiple times and nothing’s worked. Anyone else having this issue today??? It was working just fine last night so I’m not sure what’s going on.

Comments

  • IssalkIssalk Member Posts: 2
    edited March 2020

    I am currently having the same problem. Do you happen to have changed your gamertag?

    (ED: It seems like it now lets you in. Idk what I did, I just spammed a lot lmao)

  • MasterWraithMasterWraith Member Posts: 1

    Me too. I tried to restart game and console and nothing possible.


    Cheers from Spain.

  • KnightFall28901KnightFall28901 Member Posts: 16

    I have the same problem

  • aSilentCircusaSilentCircus Member Posts: 4

    Same issue, idk how this happens with every single game update.

  • Coltsteel44Coltsteel44 Member Posts: 5

    Me too, same problem. I'm willing to bet we all downloaded the new package?

  • CheersCheers Member Posts: 3,426

    Also receiving this bug.

  • KhaineGBKhaineGB Member, Mod Posts: 5,562

    On the PC, we normally fix that by clearing the cache. Apparently this is how you do that on the xbox.

    1. Press and hold the power button on the front of the Xbox until it turns off completely.
    2. Unplug the power brick from the back of the Xbox. Press and hold the power button on the Xbox several times to expel any remaining power and clear the cache.
    3. Plug in the power brick.
    4. Wait for the light on the power brick to change from white to orange.  
    5. Turn the Xbox back on as you would normally.
  • SafetySkizzorzSafetySkizzorz Member Posts: 5

    Same issue here in the US. I've gotten in a couple times since the first time I got the error, but at the end of each game I get the error code and receive no progress. Now am unable to log in. Deleted the game and set to redownload, will see if that helps after work today

  • KhaineGBKhaineGB Member, Mod Posts: 5,562

    If you've been playing and then getting the error, you can try making sure ports 7777 to 7787 are open on your router.

    Apparently that's what the xbox uses to communicate with the server.

  • SafetySkizzorzSafetySkizzorz Member Posts: 5

    Following up, after reinstalling the game on Xbox, I have successfully played one killer game. Hopefully this works for good

Sign In or Register to comment.