Home Dead by Daylight Forums Technical Issues

PC/Steam - Flickering / Glittering Light on Certain Maps

EngineerDispenserEngineerDispenser Member Posts: 52
edited July 2021 in Technical Issues

I'm not certain if this should be posted here or in the bug section. This issue has been around prior to Resident Evil's patch (since I returned to the game) and only seems to get worse over time. So, I'm writing to this forum to seek out any potential solutions from the community or any developers on the issue.

DESCRIPTION OF THE ISSUE

On certain maps, such as Gas Haven or Swamp Maps, the light textures will cause issues during the game and resort in random, distracting patterns. These patterns can actually cause an issue with gameplay performance and potentially cause a elliptic seizure. (I'm not trying to be hyperbole about this.)

EXAMPLES

On the swamp map, it appears as this weird, glittering effect. However, if enough sprint or scratch marks come across the watery texture, then it can potentially cause a red flashing effect and grows worse over time. This issue goes away if I switch the textures down to Low Quality, but I take a performance hit for a bit when I do this. So, this hinders my performance in-game as a killer and survivor, waiting for the game's engine to behave properly.

On Gas Haven, I had the light texture on the gas station glitch out. This resulted in the light texture flickering wildly throughout the entire realm, if I approached or walked away from the giant sign at certain angles. (I almost disconnected this match, because it was starting to give me a headache.) This issue didn't happen until recently.

VISUAL EXAMPLE

I decided to get into a custom game with a friend to illustrate the issue at hand with Swamp's ground textures. From what I've been told by friends, I'm not suppose to have this glitter effect with the water.

Regarding Gas Haven, I would need to try recording a few games and see if I can showcase the issue.

What have I done to try troubleshooting the issue:

  • Rolled back GPU drivers to September 2020 with the effects still existing.
  • Overclocking my CPU and RAM only made the game unstable.
  • Underclocking my CPU and RAM changed nothing.
  • Switched the game from a HDD to SSD.
  • Fresh Reinstall on the SSD.


Comments

  • KhaineGBKhaineGB Member, Mod Posts: 10,623

    Um...

    Do you want the bad news now or later?

    That's a GPU RAM issue.

  • EngineerDispenserEngineerDispenser Member Posts: 52
    edited July 2021

    Are you sure? This issue is also known on the mobile DBD version with the swamp.

    The other issue seems to be similar to what PS5 users are experiencing at the moment with 5.0.2's update.

  • KhaineGBKhaineGB Member, Mod Posts: 10,623

    Given this is the first time i've seen this issue reported here, and it's consistent with my experience of GPU RAM failure, like 95% sure... yes.

  • EngineerDispenserEngineerDispenser Member Posts: 52
    edited July 2021

    Now, it could be a potential problem, but there has been a similar issue on the mobile side of this game.

    If the mobile and desktop versions are built in similar engines (Unreal Engine), then it could be a potential problem with the clients alone.

    And this issue seems to have been reported before on Reddit, but not in great detail:

    Other than the weird performance issues came with this patch, the gameplay has been fine overall. I've did some minor underclocking on the GPU (as you've suggested to others) to ease on the hardware and there hasn't been any change in the performance.


  • EngineerDispenserEngineerDispenser Member Posts: 52
    edited July 2021

    So, I managed to eliminate the "glitter effect" by doing a small tweak onto the GameUserSettings.ini and Engine.ini settings.

    Given that this issue is eliminated immediately when switched from Ultra to Low Settings, this is an issue with specific quality settings. I started isolating specific settings, seeing what Unreal Engine setting was causing it, to identify the main culprit. Unfortunately to do this, I need to set the GameUserSettings file into "Read Only" mode, because the Client will automatically default the values back.

    This setting was the main culprit that caused the "glittering" effects:

    sg.ShadowQuality=0
    

    Once it was switched from Ultra (3) to Low (0), it stopped the annoying effects and appeared almost identical to everyone else's gameplay. Given a search through Google, this specific setting has always been an issue with this game and other UE4 titles. So, I'm happy to leave this setting off to enjoy further gameplay experience.

    As a safety measure, I also added this specific line of code into Engine.ini to prevent VRAM leakage issues.

    [TextureStreaming]
    PoolSizeVRAMPercentage=40
    

    You might not be wrong on the issue of VRAM, but it's better to be safe than sorry.

  • KhaineGBKhaineGB Member, Mod Posts: 10,623

    Huh. Interesting that it seems to be shadow related. I wonder if lowering the core speed would help...

    I may have to get on my desktop and experiment with the 2080ti.

  • EngineerDispenserEngineerDispenser Member Posts: 52

    That is odd too. I would figure it would be an effect, post-process, or a different quality setting, but that doesn't surprise me with the weird lighting bugs in UE4 I kept coming across when researching this issue.

    I have my CPU core speed lowered already, since DBD's client likes to be a resource hog on this specific aspect. I did try underclocking the GPU and it did help with other unrelated issues with performance. (This is due to 5.0.2's fix have random stuttering.)

  • KhaineGBKhaineGB Member, Mod Posts: 10,623

    Ah, I actually meant the core speed on the GPU, not your CPU.

    What happens if you increase the power limit but leave the cores as -100? So you're giving it more power, but with less speed.

  • EngineerDispenserEngineerDispenser Member Posts: 52

    Oh, the CPU underclocking was suggested by support for a different issue.

    GPU Underclocking is being tested, but it's also being tested with some changes to my V-Sync settings. I've noticed some improvements from default, but I need to do a long duration test on this and see if any issues appear after long gameplay. I boosted the power limit by 10%, but left the cores at -100.

  • KhaineGBKhaineGB Member, Mod Posts: 10,623

    Fingers crossed :)

  • EngineerDispenserEngineerDispenser Member Posts: 52

    So, after a whole evening of playing, I can conclude that it mostly went away after some of the tweaks.

    However, there is a few things worth of noting:

    • Game performance did stabilize overall with a rare spike of lag. (I assume this is likely an issue with effects or the patch itself.)
    • The glittering effect does show up from time-to-time. However, it appears much smaller and it makes the water look realistic.
    • The red flashing textures do show up, but not as often, and its related to blood and high amount of scratch marks on the texture.
    • The screen tears I had (especially notable with Freddy's dream world) disappeared after tweaking V-Sync settings. These screen tears did worsen the issues in relation to the glittering and flickering textures that I had.
    • The underclocking settings does help with the game performance, but doesn't eliminate the texture glitches altogether.
  • RyuzakiRyuzaki Member Posts: 676
    edited July 2021

    Just jumping in on this post, I have been experimenting with lowering my CPU clock speed for increased stability with DBD. It seems the game has hiccups when the clock speed boosts. Please can you share you settings and processor specs?

  • EngineerDispenserEngineerDispenser Member Posts: 52

    Clarify on what you mean by settings, but I can give you the processor specs.

    GPU: ASUS Strix GTX 1070.

    CPU: i5-4690k @ 3.50 GHz (underclocked to 3.3 GHz)

  • RyuzakiRyuzaki Member Posts: 676
    edited July 2021

    Thanks for sharing, do you have Intel turbo boost enabled?

  • EngineerDispenserEngineerDispenser Member Posts: 52
    edited July 2021

    I believe the setting is on and has been. (I'll double check right now.) Is there a specific reason why?

  • RyuzakiRyuzaki Member Posts: 676

    The game seems to perform better when I lock the clock speed, when my CPU boosts and goes back down to base I get instability.

  • EngineerDispenserEngineerDispenser Member Posts: 52
    edited July 2021

    So, it's best to disable the feature and force the CPU to hold a specific fixed or variance speed?

    I went into my BIOS (since I had to restart) and the feature is enabled.

  • EngineerDispenserEngineerDispenser Member Posts: 52
    edited July 2021

    Listening to Ryuzaki's advice, I disabled settings that allowed it to boost and drop randomly. (I do have to underclock in this game, since it becomes a resource hog and hits the "thermal limit" protocols with my CPU.) This does help with the random stuttering, but I'll need to do more through testing and see if this might be the culprit to the particular issues within' this thread.

    Here's a hour of gameplay where I was playing Wraith and Ghostface:

    The only sector I see the CPU went up was during the instance I was playing Ghostface on The Game, but the game ran smoothly.

  • KhaineGBKhaineGB Member, Mod Posts: 10,623

    You can use throttlestop to disable turbo and set all the multipliers to the max your CPU can support before turbo.

    That stops the speed bouncing around.

  • RyuzakiRyuzaki Member Posts: 676
    edited July 2021

    I have a Ryzen 5 5600X which runs pretty hot for my liking out of the box. I have been testing a fixed clock speed and undervolting to keep thermals low without hindering performance.

    After more testing it seems like a placebo as I still occasionally get fps drops with a fixed clock speed as I did with variable. For this reason, I have been exploring PBO undervolting instead which has yielded good thermals and actually not affected performance in the slightest.

    I thought maybe DBD didn't like my overclocked RAM at 3200 MHz so I tried a few games with XMP disabled but there was no improvement.

    I think the FPS drops are attributed to certain actions in a trial like status effects being applied, I think the devs are looking to address this in future patches.

  • RyuzakiRyuzaki Member Posts: 676

    Thanks for the recommendation, I will have a nosey around at this.

  • KhaineGBKhaineGB Member, Mod Posts: 10,623

    I was using it on my laptop cos I was having some really odd audio issues.

    Turns out the exhaust vents were just blocked. :D But now I use it to keep the speed somewhat consistent across all cores.

Sign In or Register to comment.