Home Technical Issues

Hi, i have a problem with running my game

scrim__scrim__ Member Posts: 10

So today i got my pc returned from my programmer, i got the new windows 10 installment and my hard drive was replaced with a better one, because it was damaged. I installed the game back, launched it and it ran very slowly, sloppy. Before this event my game used to work perfectly fine, no flaws. Now because of this update that i have done to my pc, it works very slow. I have a Nvidia GeForce GTX 1050 Ti graphics card.


If anyone knows, what this may be caused by, pls reply.

Ty, in advance.

Comments

  • MandyTalkMandyTalk Mod, Co-ordinator Posts: 9,165

    Make sure that all the windows updates have been completed - if it's a fresh install of Windows 10 you might need to run Windows Update through a few times and restart a few time before all the updates are completed.

    Also, make sure that you are using the most recent GPU driver, download this directly from Nvidia.

    Also check the game settings, making sure that the game is not set to Ultra quality for example.

  • scrim__scrim__ Member Posts: 10

    I've tried all of the possibilities listed, there's no new windows updates, installed and reinstalled my gpu drivers, have my setting on the recommended for my pc.

    Still doesn't work tho. Do you think something could've been damaged with my graphics card?

    I will also try to reinstall the game itself

  • scrim__scrim__ Member Posts: 10

    I also ran UserBenchMark. Here are the results.

    Nvidia GeForce GTX 1050 Ti -  Performing way below expectations (5th percentile), Bench: 30.9% below average, my ADM Radeon HD 7560D is performing fine. The other components are fine aswell.

  • scrim__scrim__ Member Posts: 10

    Fixed the problem. Im wuite stupid i may say. Pretty much i had 2 hdmi adapters one connected to my graphics card and the other one to my motherboard. I got rid of the motherboard one and boom

  • MandyTalkMandyTalk Mod, Co-ordinator Posts: 9,165

    At least the problem has been solved for you, glad it was nothing serious. Enjoy your games, I'll go ahead and lock this thread now.

This discussion has been closed.