The 3.2.0 update is now live on PC and consoles. For more information, click here: https://forum.deadbydaylight.com/en/discussion/87832/
We have updated our Forum Rules. Please take a moment to read through them: https://forum.deadbydaylight.com/en/discussion/87004/

Full screen dose not work properly with more than 1 monitor

So when I load up dbd on my second monitor. It loads in full screen, fine. But when I click on it to start playing it switches to my laptops monitor. My secondary monitor is set as primary, so I have no idea whats wrong.

I've tried the holding windows key and press the left and right arrow keys to move it that way, but it doesn't work.

Switching it to windowed and moving it, and setting full screen dose not work either an the game moves back to the first monitor. Nor with changing it with alt + enter.

Help please the labtop screen is kinda broken and I can't play with it. Also all other full screen games I've tried have worked.

Tagged:

Comments

  • KhaineGBKhaineGB Member, Mod Posts: 281

    What GPU does your laptop have? Pretty sure that's something we can force in the driver settings instead of just windows. :)

  • Weeb_H_ToastWeeb_H_Toast Member Posts: 10

     Operating System: Windows 10 Pro 64-bit (10.0, Build 18362) (18362.19h1_release.190318-1202)

             Language: English (Regional Setting: English)

       System Manufacturer: ASUSTeK COMPUTER INC.

           System Model: G750JH

               BIOS: BIOS Date: 07/09/13 10:55:44 Ver: 04.06.05 (type: BIOS)

            Processor: Intel(R) Core(TM) i7-4700HQ CPU @ 2.40GHz (8 CPUs), ~2.4GHz

              Memory: 16384MB RAM

       Available OS Memory: 16334MB RAM

            Page File: 7786MB used, 11491MB available

           Windows Dir: C:\WINDOWS

         DirectX Version: DirectX 12

       DX Setup Parameters: Not found

         User DPI Setting: 96 DPI (100 percent)

        System DPI Setting: 96 DPI (100 percent)

         DWM DPI Scaling: Disabled

             Miracast: Available, no HDCP

    Microsoft Graphics Hybrid: Not Supported

     DirectX Database Version: Unknown

          DxDiag Version: 10.00.18362.0267 64bit Unicode

  • Weeb_H_ToastWeeb_H_Toast Member Posts: 10

    cool cool

  • Weeb_H_ToastWeeb_H_Toast Member Posts: 10

    i don't know what in here you wanted, i woudl ike to play dbd tho so please hurry

  • SnapshotSnapshot Member Posts: 434
    edited September 7

    @Weeb_H_Toast Obviously I can think of two solutions in this situation, but remember I am not official support or anything unlike @KhaineGB

    1) A solution I am using involves Steam. Install Steam and start it up in Big Picture mode, under display settings, select the monitor you want to play the game on. By doing this steam changes the windows primary display temporarily until you leave big picture mode. You can add non steam games to your steam library as shortcuts so you can launch any game(or any other program) via Big Picture which launches on the display you chose.

    2) One option is to switching your machine to "projector only" mode. Hit "windows key" + P and select projector only mode. This will treat your machine as having only one monitor (in this case, the secondary monitor).

    You won't see any more output on your laptop screen, but you will be able to play the game fullscreen on your secondary monitor without performance loss.

    Once your game starts, you can turn off projector mode and the game will stay on your other monitor.


    PLEASE BE AWARE THAT RUNNING THE GAME IN WINDOWED MODE IS LIKELY TO RESULT IN A SIGNIFICANT PERFORMANCE HIT BECAUSE OF FRAMEBUFFER OVERHEAD (2x MEMORY TRANSFER EACH FRAME).


    good luck ^^

  • Weeb_H_ToastWeeb_H_Toast Member Posts: 10

    The game still swaps to the laptop monitor when I actual click on anything on the game.

    Launching in Big Picture doesn't seem to change this.

Sign In or Register to comment.