We are aware of an issue where the Trapper's Ornate Mask is not appearing in your items - there is no need to contact Support for this matter, we will hopefully have a resolution to this shortly.
Due to unforeseen circumstances, the Withering Blight event is postponed until the release of the mid-chapter 3.3.0. We're working on getting the update ready as soon as possible and will keep you posted.
We have updated our Forum Rules. Please take a moment to read through them: https://forum.deadbydaylight.com/en/discussion/87004/

Stuck in bloodweb (PC)

edgarpoopedgarpoop Member Posts: 955

I am running into an issue today on PC where the I am getting stuck on the bloodweb screen after completing a level 50 bloodweb on killer. It is happening with Ghostface, but it has happened to me on Clown before. I complete all the nodes on the bloodweb, and it doesn't cycle to a new one. I am unable to back out or change screens until a game starts. I can click Ready and Unready, but I can't leave the bloodweb screen.

Tagged:

Comments

  • KhaineGBKhaineGB Member, Mod Posts: 517

    That's definitely not intended behaviour. Has it been resolved after todays patch? If not, you may want to grab a log file and submit it to https://support.deadbydaylight.com

  • edgarpoopedgarpoop Member Posts: 955
    edited September 18

    I'll try to reproduce it and submit a log file tomorrow. I can get it to happen if I search for a match as Ghostface or Clown, enter the bloodweb, and complete a level 50 web before finding a lobby. Neither character is prestiged. It resolves itself once the trial is completed, but it can happen again if I repeat the steps. Definitely seems related to completing bloodwebs while searching for a match.

  • KhaineGBKhaineGB Member, Mod Posts: 517

    Oh yeah, support will definitely want logs of that then. If you can grab some screenshots too, that'd be good. :)

  • PyroGLPyroGL Member Posts: 19
    edited October 10

    I am having the identical issue when leveling up Nancy right now.

    EDIT: After Alt +F4ing, and rebooting the game, it seems to work again.

Sign In or Register to comment.