The November 2019 Developer Update is now available: https://forum.deadbydaylight.com/en/discussion/103996/
Chapter 14 Teaser:
We have updated our Forum Rules. Please take a moment to read through them: https://forum.deadbydaylight.com/en/discussion/87004/

Critical crash after cutscene

priamXuspriamXus Member Posts: 11
edited September 16 in Technical Issues

The crash happens after the intro cutscene, I never get to press a key to conutnue to the main menu even. It just crashed and maybe I can see the Window to report the crash but most of the times I dont.

The game used to work perfectly and currently every game I use to play runs maxed out most of the time @4K (Even games running the same engine)


For cerntainty I can say that after reinstalling bootcamp and just installing required Macbook drivers, the current AMD drivers, Steam and DbD the game runs fine. Theres either a distributable package or Windows update that I cant locate thats making the game to crash. (No other software running in background neither).


Besides other things tried also running the game in compability mode, as administrator, underclocking, undervolting and changing power plans.


Currrently running Windows 10 1903 updated on a bootcamp installation with an eGPU running a Vega 56. Have to say that when it crash even the eGPU shuts down completely to the point that it wont turn on, I have to unplug and plug it again. AMD Drivers are 26.20.13001.29010 (Adrenalin August Release)


I insist in case of any doubt, with several and same settings I did several synthetic performance / stress test and ingame benchmarkings. The eGPU runs just fine and its a problem specifc related to DbD only.


Hope this information serves you well and you can find a solution or tell me what to do.


-------------------------------------------------------------------------------------

Radeon Software Version - 19.8.1

Radeon Software Edition - Adrenalin 2019

Graphics Chipset - Radeon RX Vega

High Bandwidth Cache Size - 8176 MB

High Bandwidth Cache Type - HBM2

Core Clock - 1590 MHz

Windows Version - Windows 10 (64 bit)

System Memory - 16 GB

CPU Type - Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz

-------------------------------------------------------------------------------------


Game Crash Report:

Fatal error: [File:Unknown] [Line: 200] Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG')


KERNELBASE {0x0000000000000000} + 239673 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 19476797 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 19265959 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 18907081 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 23853731 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 23857686 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 23786952 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 23818361 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 28931915 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 28923158 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 34052903 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 34059537 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 18336483 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 29065282 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 29065416 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 19476091 bytes

DeadByDaylight_Win64_Shipping {0x0000000000000000} + 19438588 bytes

kernel32 {0x0000000000000000} + 96580 bytes

ntdll {0x0000000000000000} + 446065 bytes



Post edited by priamXus on

Comments

  • priamXuspriamXus Member Posts: 11
    edited September 16

    Attaching several log files to the main post.

    Post edited by priamXus on
  • priamXuspriamXus Member Posts: 11
    edited September 19

    Any update on this? Has anyone looked at it?

    Post edited by priamXus on
  • priamXuspriamXus Member Posts: 11

    With the new patch I get a new message and code now when it crashes:

    Fatal error: [File:Unknown] [Line: 200] Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0005 - 'REMOVED')


    KERNELBASE {0x0000000000000000} + 239673 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 20984045 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 20773207 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 20413641 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 25360371 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 25364326 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 25293592 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 25325001 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 30430859 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 30422102 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 35553191 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 35559825 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 19843843 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 30564226 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 30564360 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 20983339 bytes

    DeadByDaylight_Win64_Shipping {0x0000000000000000} + 20945836 bytes

    kernel32 {0x0000000000000000} + 96580 bytes

    ntdll {0x0000000000000000} + 446065 bytes

  • priamXuspriamXus Member Posts: 11
    edited October 1

    Need help :)

    Post edited by priamXus on
  • KhaineGBKhaineGB Member, Mod Posts: 712

    The reason you didn't get help is because it was posted in bug reports, not tech support.

    Now it's been moved here, I can try to help.

    So I only know a bit about macs, so I want to check something.

    When you talk about eGPU, is it a GPU connected via thunderbolt to the macbook?

  • priamXuspriamXus Member Posts: 11

    Hello Khaine, thanks so much, I was losing hope already.

    Yes. Its a Radeon Vega 56 on an external enclosure connected to Thunderbolt 3 Port. I did post it in the bug section because its the only game thats not working from my library and has to be something really specific to it.

    Everything used to work more than fine before with the game. I know AMD drivers are not the problem (They used to work and tried every single major release since december 2018 to date, now I have September Adrenalin release.) and my guess is its something related to Windows. Furthermore, cumulatives 1903 updates are reportedly to break ANY eGPU setup on whatever Desktop / Notebook, so at the moment im running 18362.30 build.

  • KhaineGBKhaineGB Member, Mod Posts: 712

    Mmmmkay, I have a suspicion then.

    What's the PSU wattage in the enclosure?

  • priamXuspriamXus Member Posts: 11

    450w tried everything including undervolting.

    Playing other games like The Division 2 I run it overclocked.

  • KevinNeverDiesKevinNeverDies Member Posts: 2

    Kind of a bump and kind of acknowledgement to the issue. My entire computer just decides to give me the middle finger and restart. I have other games that comparatively require more and run just fine. I notice wattage was mentioned earlier in the thread. I have a 750w if that means anything. I have a monster of a computer, so I'm thinking it's very likely not my hardware. I have this issue before updating drivers AND after updating. I've had a similar issue before where I've heard discord overlay clashed with the game and forced a crash. Figured that may be the issue. That no longer works. I've tried at least 5 times with no luck. Crashes at the same point every single time. Someone did mention something about the resolution though. Apparently if you run the game directly from the .exe file, tab out of full screen, then go back into the game, it'll work? That also failed.


    Sorry if I'm just regurgitating the issue. Frustration has set in and I just want to run DbD with no issues :(

  • priamXuspriamXus Member Posts: 11

    Yup, agree 100% with the last part, tried several resolutions and dropping the graphics quality. Windows 1709 with previous release of the game used to work perfect. 1903 combined with recent releases wont work at all.

  • KevinNeverDiesKevinNeverDies Member Posts: 2

    Believe it or not, I just tried to log in just to try it, and it actually let me in. The only change I see if the "Dedicated Server" update. Otherwise, my PC, my connection, or anything that could possibly be related all stayed the same. Maybe a wonky patch?

  • KhaineGBKhaineGB Member, Mod Posts: 712

    Okay, i'm just gonna go ahead and say this.

    "But I have a monster computer..." Ok, and?

    "But other games.." Ok... so what?

    I had a PC with a 750W PSU that ran every single game I threw at it with 0 issues... except DbD. I'd either get D3D_DEVICE_LOST or I'd get a full system shut down. I partially fixed the DEVICE_LOST issue with some mild underclocking, taking the GPU out, repasting it, cleaning out the fans and putting it back in. THEN I just had the restarting issue.

    Ignored it, went on holiday, came back and the PC wouldn't start anymore. PSU died. Once I replaced that? Everything was working fine.

    So it can absolutely 100% be either your card needing a clean (even if temps are absolutely fine, like mine were) or a PSU that's starting to fail (even if everything else runs fine). There's something about DbD that pushes hardware in JUST the right way to make it fail if it's going bad.

    Therefore that's where I'd start. Take the card out, check for dust and such, maybe give it a repaste with Kryonaught if you are technically competent enough. If that doesn't work, get another PSU and test. Especially for the user with Thunderbolt and Vega because Vega is a power hungry monster.

  • priamXuspriamXus Member Posts: 11
    edited October 4

    Pretty rude answer honestly, you dont even know my background and assume several things, plus ignoring the most important ones (Like if I do a clean install of .1709 the game works fine, or at least was, cant say for sure with latest pataches but I assume it does)

    Second,, eGPU, both PSU and Vega are 3 months old, I told you I tried unvervolting it too, so even when it consumes @183w with graphics at minimum, windowed and FHD res it will crash? But consuming over @285w overclocked, higher temps, 4K res, all maxed out in more than 25+ games at least its the GPU?

    Really....


    Background: More than 9 IT certifications and 12 years in the area. Its not the GPU neither the PSU. This is more than checked with .1709 and first assumption taken reading the logs.


    EDIT: One more thing. Tried Parallels 15 loading Bootcamp Windows installation as a VM machine that simulates DirectX using Metal 2 API. The game runs fine. Although its a trial version and I cant run it maxed out.

  • priamXuspriamXus Member Posts: 11

    With all due respect I think you are being kinda rude, assuming several things and ignoring others as stated before. All this ignoring possible background that one might have.

    First, and most important, as I said, clean install one month ago .1709 worked perfectly fine. Today with latests patch cant say for sure, but I assume it would.

    Second, Vega, PSU and eGPU are around 3 months all, they are working fine. Plus again a combination of things, lets say one of the components is failing (Which we know they are not as previous statement), even though you are saying that because running DbD in FHD res, low details, with the GPU undervolted peaking the @195w but with OC peaking @255w in other games (25+ at least) maxed out at 4K res nevertheless its the PSU or the Vega... Something clearly doesn’t add so well here, specially if you consider that the PSU is only and exclusively being used for the Vega and nothing else.

    Third, just tried this morning Parallels 15 sideloading the Bootcamp Windows installation and simulating (not emulating) DirectX using Metal 2 API. The game runes fine and the GPU is being pushed hard under macOS since I have no control at all of the voltage and others factors. Limited tryout/solution but I’m confirming again its not the GPU/PSU/eGPU.


    Background: +10 years of experience in the IT industry, more than 9 certifications and still going. Currently beta testing for several companies and even in alpha projects the GPU runs fine and in some cases peaking @295w. Tested several times.

  • KhaineGBKhaineGB Member, Mod Posts: 712

    Oh I'm not being rude. I'm being blunt because I hear those excuses A LOT. And every time I have, I've suggested a new PSU and the problem has been fixed.

    Clean install doesn't mean much, other than you eradicated one potental vector for failure. Not a bad thing.

    Even at 3 months old, you can still get a PSU with bad parts that pass checks, but start to fail fairly quickly. Already had 1 user in these forums within the past couple of weeks with that exact issue.

    Going by the fact parallels is basically taking over the D3D instructions via metal, it sounds like windows just doesn't particularly like eGPU setups, which is odd when you consider that laptops like the Razer Blade have a TB3 port.

    And if you REALLY want to play the background card...

    25+ years building and repairing PC's, about 3 years in IT because it's a nightmare to get IT jobs over here for some reason, degree in computer science, beta tester for a couple of game companies NOW, and several more in the past, and working on my own projects in Unity (just updated to 2019)

    So please don't try to use that as if you're talking to someone who doesn't know what they're doing. I do. I just have little experience with mac's and external GPU's because I dislike macs and literally wouldn't use one unless I was either in a band (because the music apps on there are FANTASTIC) or porting a unity project to macOS (which is the only reason I have a hackintosh).

  • priamXuspriamXus Member Posts: 11

    Well. There’s a known eGPU site/forum and everyone is complaining about how Windows is killing every single eGPU setup after 1903 cumulative updates.

    Yes. I know the facts. But theses are my facts and I know it’s not the GPU neither the PSU. I have a 1050 around somewhere to give a try. I’ll and report back.

    And I’m not judging or saying that you don’t know what you are doing, I’m implying that you are taking for granted what I’m saying and the given facts because you are the one implying those facts to my person.

  • KhaineGBKhaineGB Member, Mod Posts: 712
    edited October 5

    Stupid thought. I don't really know the difference between parallels and bootcamp (other than bootcamp actually installs windows as a dual boot with applicable drivers).

    Therefore, incoming stupid idea because i'm still absolutely sure it's power related...

    Is windows power management messing with the TB port when using bootcamp?

    EDIT: Just did some research and noticed Parallels is a VM. Still going with that thought since it'd make sense Parallels doesn't have full power management control over the TB port, while bootcamp would.

Sign In or Register to comment.