Home Technical Issues
The 4.3.0 PTB starts today. For more information and patch notes, click here.

Error 30004

BeanSnippingBeanSnipping Member Posts: 2
edited December 2019 in Technical Issues

My Dead by Daylight always fails to start for some reason? Whenever I start it I get the Error Code 30004 and it tells me "WaitForSingleObject failed : 2" and I don't know what causes it, I have a decent PC that allows me to run DBD on 70+ on low settings, and it's only Dead by Daylight. I've tried to search for a fix on google, but all the posts are from 2017 and have been deleted by Steam.

Fixes I've tried :

Reinstalling Dead by Daylight

Deleting my entire Dead by Daylight and Verifying Integrity of my game Files, basically a fresh install

Repairing / Reinstalling Easy Anti Cheat

Deleting the EAC folder out of my DBD folder, and verifying.

Scanning my Windows for any corrupted files.

Any thoughts would be helpful, as I don't want to reformat my computer to fix it.


  • Slay___Slay___ Member Posts: 612
    edited December 2019

    Did your scan find any problems with your Windows?

    If not it could be your anti-virus automatically blocking suspicious operations performed by software ("Live scanning"). If your anti-virus has such feature try whitelisting Steam, EAC and Dead by Daylight. Or you can try fully turning that feature off until EAC has performed the action and then re-enable the feature.

    Or you can try booting your Windows into safe mode/boot instead and install EAC there, make sure to select safe boot + network, else Internet connection is disabled blocking the install.

    If you are Googling for Dead by Daylight + error then they aren't deleted by Steam but rather deleted or hidden by the Dead by Daylight moderators on the Steam forums because all technical issues and bug reports are now being directed here instead of Steam. It's a shame really, a lot of those threads are still useful to some people. If a moderator is reading this please change them to readable format without ability to make new threads.

    So if you continue Googling I would suggest just generic search for all games using EAC since the issue is just EAC and Windows, game is irrelevant. Or just contact Easy Anti-Cheat support directly, https://easy.ac/en-us/support/

    EDIT: Googling this also suggests that Malwarebytes could be the cause if you one installed.

  • BeanSnippingBeanSnipping Member Posts: 2

    The scan didn't find anything wrong, and I'm currently looking into my anti-virus software and other programs, I'll keep this thread updated

  • ov3rclockedov3rclocked Member Posts: 1

    I fixed this problem with other games, in particular, hi-rez studios games. The problem is within the Easy Anti-Cheat (EAC) file. I fixed this problem by going to This PC | OS (c:) | Program Files x86 | Steam | Steamapps | common | Smite | Binaries | EasyAntiCheat | Easyanticheat_setup. This will take you to the EAC launcher and you should be given an option to "fix".

    Now, I know that this is a Dead by Daylight forum, so you would change "smite" for the "dead by daylight" folder, the rest of the folders should still be named the same.

    Hope this helps!

  • ArthurPArthurP Member Posts: 1

    so i tried everything like you and nothing worked haven't you find anything to fix this yet ?i was having so much fun playing the game and this happen, im so sad right now.

Sign In or Register to comment.